Home Questions output trigger

output trigger

DWQA QuestionsCategory: Sample Tasksoutput trigger
Joseph Galea asked 8 years ago
Hi,  From my task loop I am sending a 0 or 5 signal to 'PCI-6229 analog output'. Using a scope I can see that when a trial starts this changes to 5 and then gets reset to 0 so I am confident it is receiving the correct input. Through AO0 on the national instrument board I have attached a BNC lead which should trigger another piece of equipment (either TMS or a sound box). On most trials this works fine however every so often the A0o does not send an output... On these trials, the scope shows it received the correct value of 5 so it should have sen an output. I have tried using a differnet A0 port, a different BNC cable and different equipment to trigger and nothing helps so I am confident it is something to do with the 'PCI-6229 analog output' but I am just not sure what. regards, Joe            
1 Answers
Duncan McLean Staff answered 8 years ago
Hi Joseph, It sounds like you have things set up correctly, but just to double check:
  1. You are using the simulink block called PCI-6229 National Instr. Analog Output
  2. When connected to AO-0 your settings in the block are:
  3. Channel Vector=[1], Reset vector = [1], Initial value vector=[0]
If those settings are all correct then we can go on to a few more possibilities. How long are you trying to change the analog output value for? If the analog output block is set to run at 1Khz and you are passing it input from stateflow which runs at 2KHz and only changing for 1 frame then it's likely that the analog output block is never seeing your change. If you try to change the output for more time then will it always work? Have you tried this using the digital outputs? If none of that help please send an email to support@bkintechnologies with a copy of your model. Cheers! Duncan